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Introduction
Thank you for choosing the Lattice Semiconductor MachXO™2280 Breakout Board Evaluation Kit! 

This user’s guide describes how to start using the MachXO2280 Breakout Board,  an easy-to-use platform for eval-
uating and designing with the MachXO2280 PLD. Along with the board and accessories, this kit includes a pre-
loaded demonstration design. You may also reprogram the on-board MachXO2280 device to review your own cus-
tom designs.

Note: Static electricity can severely shorten the lifespan of electronic components. See the Storage and Handling
section of this document for handling and storage tips.

Features
The MachXO2280 Breakout Board Evaluation Kit includes:

• MachXO2280 Breakout Board – The board is a 3” x 3” form factor that features the following on-board compo-
nents and circuits:

– MachXO2280 PLD (LCMXO2280C-3FTN256C)
– USB mini-B connector for power and programming
– Eight LEDs
– 40-hole prototype area
– Eight 2x20 expansion header landings for general I/O, JTAG, and external power
– 1x8 expansion header landing for JTAG 
– 3.3V supply rail

• Pre-loaded Demo – The kit includes a pre-loaded counter design that highlights use of the embedded 
MachXO2280 oscillator and programmable I/Os configured for LED drive.

• USB Connector Cable – The board is powered from the USB mini-B socket when connected to a host PC. The 
USB channel also provides a programming interface to the LCMXO2280C JTAG port. 

• Lattice Breakout Board Evaluation Kits Web Page – Visit www.latticesemi.com/breakoutboards for the latest 
documentation (including this guide), demo designs, and drivers for the kit.

The content of this user’s guide includes demo operation, programming instructions, top-level functional descrip-
tions of the Breakout Board, descriptions of the on-board connectors, and a complete set of schematics.

http://www.latticesemi.com/Breakoutboards/
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Figure 1. MachXO2280 Breakout Board, Top Side
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Storage and Handling
Static electricity can shorten the lifespan of electronic components. Please observe these tips to prevent damage 
that could occur from electro-static discharge:

• Use anti-static precautions such as operating on an anti-static mat and wearing an anti-static wrist-band.

• Store the evaluation board in the packaging provided.

• Touch a metal USB housing to equalize voltage potential between you and the board.

Software Requirements
You should install the following software before you begin developing new designs for the Breakout board:

• FTDI Chip USB Hardware Drivers

• Lattice Diamond™ (MachXO support)

• ispVM System™ 17.9 or later (Required for re-programming)

MachXO2280 Device
This board features the MachXO2280 PLD which offers the benefits of increased system integration by providing 
over 27Kbits of embedded memory, two built-in PLLs, high performance LVDS I/Os, and a low power sleep mode, 
all in a single-device. The 256-pin ftBGA package provides 211 user I/Os in a 17mm x 17mm package. A complete 
description of this device can be found in the MachXO Family Data Sheet. 

www.latticesemi.com/dynamic/view_document.cfm?document_id=9922
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Demonstration Design
Lattice provides a pre-programmed demo to illustrate basic operation of the MachXO2280 device. The design inte-
grates an up-counter with the on-chip oscillator.

Note: You may obtain your Breakout Board after it has been reprogrammed. To restore the factory default demo 
and program it with other Lattice-supplied examples see the Download Demo Designs section of this document.

Run the Demonstration Design
The preprogrammed demonstration design is an up-counter to drive an LED array. The program shows a clock 
generator based on the MachXO2280 on-chip oscillator. The counter module is clocked at ~22 MHz (18-26MHz) to 
illustrate how low speed timer functions can be implemented with a PLD. The 23-bit up-counter further divides the 
clock to advance the LED display approximately every 200ms. The resulting light pattern will appear as an alternat-
ing pair of lit LEDs per row. 

Figure 2. Counter Demo Block Diagram
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WARNING: Do not connect the Breakout Board to your PC before you follow the driver installation procedure of this 
section.

Communication with the Breakout Board with a PC via the USB connection cable will require the FTDI chip USB 
hardware drivers contained in the Software Requirements section. Loading these drivers enables the computer to 
reliably recognize and program the Breakout Board. Drivers are distributed by Lattice as a stand-alone package or 
with ispVM System version 17.9 or later. Use one of the two procedures below to install. 

To load the FTDI chip USB hardware drivers via ispVM System:

1. Browse to www.latticesemi.com/breakoutboards and download ispVM System software.

2. Install ispVM System software.

3. Run ispVM System. Choose ispTools > Install/Uninstall LSC USB/Parallel Port Driver.
The LSC 32/64-Bit USB Drivers Install/Uninstall dialog appears.

4. Select FTDI USB 32-Bit Driver or FTDI USB 64-Bit Driver then click Install.
After a few moments, ispVM will indicate the installation is complete.

5. Click OK, then click Close from the LSC 32/64-Bit USB Drivers Install/Uninstall dialog.

6. Choose File > Exit to close ispVM System.

7. Connect the USB cable from a USB port on your PC to the board’s USB mini-B socket (J2). After connection is 
made, a green Power LED (D9) will light indicating the board is powered on. 

8. Red LEDs will light and start to flash according to the preprogrammed demonstration design.

See the Troubleshooting section of this guide if the board does not function as expected.

www.latticesemi.com/breakoutboards
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To load the FTDI chip USB hardware drivers via the stand-alone package:

1. Browse to www.latticesemi.com/breakoutboards and download the FTDI chip USB Hardware driver package.

2. Extract the FTDI chip USB Hardware driver package to your PC hard drive.

3. Connect the USB cable from a USB port on your PC to the board’s USB mini-B socket (J2). After connection is 
made, a green Power LED (D9) will light indicating the board is powered on. 

4. If you are prompted, “Windows may connect to Windows Update” select No, not this time from available 
options and click Next to proceed with the installation. Choose the Install from specific location (Advanced) 
option and click Next. 

5. Search for the best driver in these locations and click the Browse button to browse to the Windows driver folder 
created in the Download Windows USB Hardware Drivers section. Select the CDM 2.04.06 WHQL Certified 
folder and click OK.

6. Click Next. A screen will display as Windows copies the required driver files. Windows will display a message 
indicating that the installation was successful.

7. Click Finish to install the USB driver.

8. Red LEDs will light and start to flash according to the preprogrammed demonstration design.

See the Troubleshooting section of this guide if the board does not function as expected.

Download Demo Designs
The counter demo is preprogrammed into the Breakout Board, however over time it is likely your board will be mod-
ified. Lattice distributes source and programming files for demonstration designs compatible with the Breakout 
Board. 

To download demo designs:

1. Browse to the Lattice Breakout Board Evaluation Kits web page (www.latticesemi.com/breakoutboards) of the 
Lattice web site. Select MachXO Breakout Board Demo Source and save the file.

2. Extract the contents of MachXO2280_BB_Eval_Kit_v01.0.zip to an accessible location on your hard drive.

The demo design directory Demo_LED is unpacked.

Recompile a Demonstration Project with Lattice Diamond
Use the procedure described below to recompile a demo project for the Breakout Board. 

1. Install and license Lattice Diamond software.

2. Download the demo source files from the Lattice Breakout Board Evaluation Kits web page. 

3. Run Lattice Diamond.

4. Open the Demo_LED_OSC.ldf project file.

5. From the Process view, select JEDEC File from the Export Files process.

6. Choose Export Files, right-click and choose Run.
After a few moments the JEDEC programming file is output.

7. See section the Programming with ispVM section for details on downloading a programming file to the board.

www.latticesemi.com/breakoutboards
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Programming with ispVM
A demonstration design is pre-programmed into the Breakout Board by Lattice. To restore a Breakout Board to fac-
tory settings or load an alternative demo design, use the procedures in this section.

To install ispVM programming tools:

1. Install and license ispVM System software.

2. Connect the board to a host PC using the USB port header connection.

3. Follow the USB Cable Interface procedure below to program the evaluation board.

The Breakout Board is equipped with a built-in USB-based programming circuit. This consists of a USB PHY and a 
USB connector. When the board is connected to a PC with a USB cable, it is recognized by the ispVM System soft-
ware as a USB Download Cable. The MachXO2280 can then be scanned and programmed using the ispVM Sys-
tem software. 

To program a demo programming file:

1. From the Start menu run ispVM System.
ispVM appears.

2. Choose Options > Cable and IO Port Setup…
The Cable and I/O Port Setup dialog appears.

3. Make the following selections:
Cable Type: USB2
Port Setting: FTUSB-0
Click OK.

4. Choose ispTools > Scan Chain.
The New Scan Configuration Setup window appears. The LCMXO2280C device appears in the device list.

5. Right-click the LCMXO2280C entry and choose Edit Device…
The Device Information dialog appears.

6. From the Data File section, click the Browse button.
The Open Data File dialog appears.

7. Browse to the <Demo Dir> folder, select <Demo>.jed, and click Open. From the Operation list choose Erase, 
Program, Verify and click OK.

8. Choose Project > Download.
ispVM reprograms the evaluation board.

Programming requires about 10 seconds. A small timer window will appear to show elapsed programming time. At 
the end of programming, the configuration setup window should show a PASS in the Status column.

MachXO2280 Breakout Board
This section describes the features of the MachXO2280 Breakout Board in detail.

Overview
The Breakout Board is a complete development platform for the MachXO2280 PLD. The board includes a prototyp-
ing area, a USB program/power port, an LED array, and header landings with electrical connections to most of the 
PLD’s programmable I/O, power, and JTAG pins. The board is powered by the PC’s USB port or optionally with 
external power. You may create or modify the program files using Diamond software and reprogram the board 
using ispVM software. 
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Figure 3. MachXO2280 Breakout Board Block Diagram
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Table 1 describes the components on the board and the interfaces it supports.

Table 1. Breakout Board Components and Interfaces

Component/Interface Type
Schematic 
Reference Description

Circuits

USB Controller Circuit U2: FT2232H USB-to-JTAG interface and dual USB UART/FIFO IC

USB Mini-B Socket I/O J1:USB_MINI_B Programming and debug interface

Components

LCMXO2280C PLD U4: LCMXO2280C-
3FTN256C 2280-LUT device packaged in a 17 x 17mm, 256-ball ftBGA.

Interfaces

LED Array Output D8-D1 Red LEDs

Eight 2x20 Header 
Landings I/O

J3: header_2x20
J4: header_2x20
J5: header_2x20
J6: header_2x20
J7: header_2x20
J8: header_2x20
J9: header_2x20
J10: header_2x20

User-definable I/O

1x8 Header Landing I/O J1: header_1x8 Optional JTAG interface

4-Hole Prototype Area Prototype area 100mil centered holes.
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Subsystems
This section describes the principle sub systems for the Breakout Board in alphabetical order. 

Clock Sources
All clocks for the counter demonstration designs originate from the MachXO2280 PLD on-chip oscillator. You may 
use an expansion header landing to drive a PLD input with an external clock source.

Expansion Header Landings
The expansion header landings provide access to user GPIOs, primary inputs, clocks, and VCCO pins of the 
MachXO2280. The remaining pins serve as power supplies for external connections. Each landing is configured as 
one 2x20 100 mil. 

Table 2. Expansion Connector Reference

Item Description

Reference Designators J3, J4, J5, J6, J7, J8, J9, J10

Part Number header_2x20

Table 3. Expansion Header Pin Information (J3)

Pin Number Function MachXO2280 Ball

1 PL2A_LV_T E4

2 PL11A_LV_T H2

3 PL2B_LV_T E5

4 PL11B_LV_C J2

5 GND n/a

6 GND n/a

7 PL3A_LV_T F5

8 PL12A_LV_T J1

9 PL3B_LV_C F6

10 PL12B_LV_C K1

11 GND n/a

12 GND n/a

13 PL4A_LV_T E3

14 PL13A_LV_T L1

15 PL4B_LV_C E2

16 PL13B_LV_C M1

17 GND n/a

18 GND n/a

19 PL5A_LV_T B1

20 PL15A_LV_T L3

21 PL5B_LV_C C1

22 PL15B_LV_C M3

23 GND n/a

24 GND n/a

25 PL7A_LV_T F2

26 PL16A_LV_T J4

27 PL7B_LV_C G2

28 PL16B_LV_C J5
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29 GND n/a

30 GND n/a

31 PL8A_LV_T G4

32 PL17A_LV_T K5

33 PL8B_LV_C G5

34 PL17B_LV_C K4

35 GND n/a

36 GND n/a

37 PL9A_LV_T H4

38 PL18A_LV_T M5

39 PL9B_LV_C H5

40 PL18B_LV_C M4

Pin Number Function MachXO2280 Ball
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Table 4. Expansion Header Pin Information (J4)

Pin Number Function MachXO2280 Ball

1 PL3C F3

2 GND n/a

3 PL3D F4

4 GND n/a

5 PL4C C3

6 GND n/a

7 PL4D C2

8 GND n/a

9 PL6C D2

10 GND n/a

11 PL6D D1

12 GND n/a

13 PL7C E1

14 GND n/a

15 PL7D F1

16 GND n/a

17 PL8C G3

18 GND n/a

19 PL8D H3

20 GND n/a

21 PL10C G1

22 GND n/a

23 PL10D H1

24 GND n/a

25 NC NC

26 PL15C M2

27 NC NC

28 PL15D N2

29 PL11C J3

30 PL16C R1

31 PL11D K3

32 PL16D R2

33 PL12C K2

34 PL17C L5

35 PL12D L2

36 PL17D L4

37 PL14C N1

38 PL19A N4

39 PL14D P1

40 PL19B N3
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Table 5. Expansion Header Pin Information (J5)

Pin Number Function MachXO2280 Ball

1 PT2C B2

2 PT9A D8

3 PT2D B3

4 PT9C E8

5 PT3A A2

6 PT9D E9

7 PT3B A3

8 PT10A A10

9 PT3C D3

10 PT10C C9

11 PT3D D4

12 PT10D C10

13 PT4A C4

14 PT10E D9

15 PT4B C5

16 PT10F D10

17 PT5A D6

18 PT11A B9

19 PT5B D5

20 PT11B B10

21 PT5C B4

22 PT12A A11

23 PT5D B5

24 PT12B A12

25 PT6E E7

26 PT12C B11

27 PT6F E6

28 PT12D B12

29 PT6C A5

30  PT13C C11

31 PT6D A4

32 PT13D C12

33 PT6A C6

34 PT14A A13

35 PT6B C7

36 PT14B A14

37 PT7A B6

38 PT14C D11

39 PT7B B7

40 PT14D D12
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Table 6. Expansion Header Pin Information (J6)

Pin Number Function MachXO2280 Ball

1 VCIO_extB7 G6

2 GND n/a

3 VCIO_extB6 J6

4 GND n/a

5 VCIO_extB5 L7

6 GND n/a

7 VCIO_extB4 L9

8 GND n/a

9 VCIO_extB3 J11

10 GND n/a

11 VCIO_extB2 G11

12 GND n/a

13 VCIO_extB1 F9

14 GND n/a

15 VCIO_extB0 F7

16 GND n/a

17 NC NC

18 NC NC

19 NC NC

20 NC NC

21 NC NC

22 PT15A E10

23 NC NC

24 PT15B E11

25 NC NC

26 PT15C B13

27 NC NC

28 PT15D C13

29 PT7C A6

30 PT16A B14

31 PT7D A7

32 PT16B C14

33 PT8C B8

34 PT16C A15

35 PT8D C8

36 PT16D B15

37 NC NC

38 GND n/a

39 NC NC

40 GND n/a
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Table 7. Expansion Header Pin Information (J7)

Pin Number Function LCMXO2280C Ball

1 PR4C F13

2 GND n/a

3 PR4D F12

4 GND n/a

5 PR5C B16

6 GND n/a

7 PR5D C16

8 GND n/a

9 PR6C D16

10 GND n/a

11 PR6D E16

12 GND n/a

13 PR7C F16

14 GND n/a

15 PR7D G16

16 GND n/a

17 PR9C H12

18 GND n/a

19 PR9D H13

20 GND n/a

21 PR10C G15

22 GND n/a

23 PR10D H15

24 GND n/a

25 NC NC

26 PR15C M16

27 NC NC

28 PR15D N16

29 PR11C J12

30 PR16C L12

31 PR11D K12

32 PR16D L13

33 PR13C J14

34 PR17C M12

35 PR13D K14

36 PR17D M13

37 PR14C K16

38 PR20A L11

39 PR14D L16

40 PR20B M11
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Table 8. Expansion Header Pin Information (J8)

Pin Number Function MachXO2280 Ball

1 PR3A_LV_T D14

2 PR11A_LV_T H16

3 PR3B_LV_C D13

4 PR11B_LV_C J16

5 GND n/a

6 GND n/a

7 PR4A_LV_T E13

8 PR13A_LV_T J15

9 PR4B_LV_C E12

10 PR13B_LV_C K15

11 GND n/a

12 GND n/a

13 PR5A_LV_T E14

14 PR14A_LV_T J13

15 PR5B_LV_C F14

16 PR14B_LV_C K13

17 GND n/a

18 GND n/a

19 PR6A_LV_T C15

20 PR15A_LV_T L15

21 PR6B_LV_C D15

22 PR15B_LV_C  M15

23 GND n/a

24 GND n/a

25 PR7A_LV_T E14

26 PR16A_LV_T L14

27 PR7B_LV_C F15

28 PR16B_LV_C M14

29 GND n/a

30 GND n/a

31 PR9A_LV_T G12

32 PR17A_LV_T N15

33 PR9B_LV_C G13

34 PR17B_LV_C N14

35 GND n/a

36 GND n/a

37 PR10A_LV_T G14

38 PR18A_LV_T N13

39 PR10B_LV_C H14

40 PR18B_LV_C N12
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Table 9. Expansion Header Pin Information (J9)

Pin Number Function MachXO2280 Ball

1 VCC_3.3V n/a

2 GND n/a

3 VCC_3.3V n/a

4 GND n/a

5 VCC_3.3V n/a

6 GND n/a

7 NC NC

8 GND n/a

9 NC NC

10 VCC_CORE n/a

11 CLK0 (PT9B) D7

12 GND n/a

13 CLK1 (PT10B) A9

14 GND n/a

15 CLK2 (PB10F) N9

16 GND n/a

17 CLK3 (PB10B) M9

18 GND n/a

19 NC NC

20 NC NC

21 NC NC

22 NC NC

23 SLEEPN P13

24 GND n/a

25 PB14D R14

26 GND n/a

27 PB15A T14

28 GND n/a

29 PB15B T15

30 GND n/a

31 PB15D P14

32 GND n/a

33 PB16A R15

34 GND n/a

35 PB16B R16

36 GND n/a

37 PB16C P15

38 GND n/a

39 PB16D P16

40 GND n/a
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Table 10. Expansion Header Pin Information (J10)

Pin Number Function MachXO2280 Ball

1 PB9B P8

2 PB2A P2

3 PB9A P7

4 PB2B P3

5 PB10E N8

6 PB2C N5

7 PB10C P9

8 PB2D N6

9 PB10D P10

10 PB3A T2

11 PB10A M10

12 PB3B T3

13 PB11C R9

14 PB3C R4

15 PB11D R10

16 PB3D R5

17 PB12A T10

18 PB4A P5

19 PB12B T11

20 PB4B P6

21 PB12C N10

22 PB4C T5

23 PB12D N11

24 PB4D T4

25 PB13A R11

26 PB5A R6

27 PB13B R12

28 PB5B T6

29 PB13C P11

30 PB6A T8

31 PB13D P12

32 PB6B T7

33 PB14A T13

34 PB7C M7

35 PB14B T12

36 PB7D M8

37 PB14C R13

38 PB8C R7

39 NC NC

40 PB8D R8
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Figure 4. J3/J4 Header Landing Callout
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Figure 6. J7/J8 Header Landing Callout
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Figure 7. J9/J10 Header Landing Callout
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Figure 8. J1 Header Landing and LED Array Callout
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MachXO2280 PLD
The LCMXO2280C-3FTN256C is a 256-ball BGA package PLD device which provides 211 I/Os in a 17 x 17mm 
package.

Table 11. MachXO PLD Interface Reference

Item Description

Reference Designators U4

Part Number LCMXO2280C-3FTN256C

Manufacturer Lattice Semiconductor

Web Site www.latticesemi.com

JTAG Interface Circuits
For power and programming an FTDI USB UART/FIFO IC converter provides a communication interface between a 
PC host and the JTAG programming chain of the Breakout Board. The USB 5V supply is also used as a source for 
the 3.3V supply rail. A USB mini-B socket is provided for the USB connector cable.

http://www.latticesemi.com/
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Table 12. JTAG Interface Reference

Item Description

Reference Designators U2

Part Number FT2232HL

Manufacturer Future Technology Devices International (FTDI)

Web Site www.ftdichip.com

Table 13. JTAG Programming Pin Information

Description MachXO2280 Pin

Test Data Output 107:TDO

Test Data Input 2:TDI

Test Mode Select 74:TMS

Test Clock 35:TCK

LEDs
A green LED (D9) is used to indicate USB 5V power. Eight red LEDs are driven by I/O pins of the MachXO2280 
device.

Table 14. Power and User LEDs Reference

Item Description

Reference Designators D1, D2, D3, D4, D5, D6, D7, 
D8, D9

Part Number LTST-C190KRKT (D1-D8) 
LTST-C190KGKT (D9)

Manufacturer Lite-On It Corporation

Web Site www.liteonit.com

Power Supply
3.3V supply rail is converted from the USB 5V interface when the board is connected to a host PC. 

Test Points
In order to check the various voltage levels used, test points are provided:

• TP1, VCC3D (VCCIO Bank 0)

• TP2, VCC3D (VCCIO Bank 1)

• TP3, VCC3D (VCCIO Bank 4)

• TP4, VCC3D (VCCIO Bank 5)

• TP5, VCC3D (VCCIO Bank 2)

• TP6, VCC3D (VCCIO Bank 3)

• TP7, VCC3D (VCCIO Bank 7)

• TP8, VCC3D (VCCIO Bank 6)

• TP9, VCC3D (VCC Core)

• TP10, VCC3D (VCCAUX)



21

MachXO2280 Breakout Board
Lattice Semiconductor  Evaluation Kit User’s Guide 

USB Programming and Debug Interface 
The USB mini-B socket of the Breakout Board serves as the programming and debug interface.

JTAG Programming: For JTAG programming, a preprogrammed USB PHY peripheral controller is provided on the 
Breakout Board to serve as the programming interface to the MachXO2280 PLD. 

Programming requires the ispVM System software.

Table 15. USB Interface Reference

Item Description

Reference Designators U2

Part Number FT2232HL

Manufacturer Future Technology Devices International (FTDI)

Web Site www.ftdichip.com

Board Modifications
This section describes modifications to the board to change or add functionality.

Bypassing the USB Programming Interface
The USB programming interface circuit (USB Programming and Debug Interface section) may be optionally 
bypassed by removing the 0 ohm resistors: R3, R4, R7, and R9 ( See Appendix A. Schematics, Sheet 2 of 5). 
Header landing J1 provides JTAG signal access for jumper wires or a 1x8 pin header.

Applying External Power
The Breakout Board is powered by the circuit of Schematic Sheet 2 of 4 based on the 5V USB power source. You 
may disconnect this power source by removing the 0 ohm resistors: R47 (VCCIO 3.3V, Bank 0), R48 (VCCIO 3.3V, 
Bank 1), R53 (VCCIO 3.3V, Bank 4), R54 (VCCIO 3.3V, Bank 5), R55 (VCCIO 3.3V, Bank 2), R56 (VCCIO 3.3V, 
Bank 3), R57 (VCCIO 3.3V, Bank 6), R58 (VCCIO 3.3V, Bank 7), R160 (VCC core) and R162 (VCCAUX). Power 
connections are available from the expansion header landing, J9, Schematic Sheet 3 of 5. 

Measuring Bank and Core Voltages
Test points (TP1, through TP10) provide access to power supplies of the MachXO2280 PLD. 0 ohm resistors: R47 
(VCCIO 3.3V, Bank 0), R48 (VCCIO 3.3V, Bank 1), R53 (VCCIO 3.3V, Bank 4), R54 (VCCIO 3.3V, Bank 5), R55 
(VCCIO 3.3V, Bank 2), R56 (VCCIO 3.3V, Bank 3), R57 (VCCIO 3.3V, Bank 6), R58 (VCCIO 3.3V, Bank 7), R160 
(VCC core) and R162 (VCCAUX)can be removed to add a current meter inline or add a resistor shunt to measure 
voltage across. 

Mechanical Specifications
Dimensions: 3 in. [L] x 3 in. [W] x 1/2 in. [H]

Environmental Requirements
The evaluation board must be stored between -40° C and 100° C. The recommended operating temperature is 
between 0° C and 90° C.

The board can be damaged without proper anti-static handling.

Glossary
PLD: Programmable Logic Device

DIP: Dual in-line package

LED: Light Emitting Diode.

LUT: Look Up Table
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PCB: Printed Circuit Board

RoHS: Restriction of Hazardous Substances Directive

USB: Universal Serial Bus

WDT: Watchdog Timer

Troubleshooting
Use the tips in this section to diagnose problems with the Breakout Board. 

LEDs Do Not Flash

If power is applied but the board does not flash according to the preprogrammed counter demonstration then it is 
likely the board has been reprogrammed with a new design. Follow the directions in the Demonstration Design sec-
tion to restore the factory default.

USB Cable Not Detected

If ispVM System does not recognize the USB cable even after installing the Lattice USB port drivers and rebooting, 
the incorrect USB driver may have been installed. This usually occurs if you attach the board to your PC prior to 
installing the USB driver or ispVM System software.

To access the Troubleshooting the USB Driver Installation Guide:

1. Start ispVM System and choose Options > Cable and I/O Port Setup.
The Cable and I/O Port Setup Dialog appears.

2. Click the Troubleshooting the USB Driver Installation Guide link.
The Troubleshooting the USB Driver Installation Guide document appears in your system’s PDF file reader.

3. Follow the directions of the guide to install the Lattice USB driver.

Determine the Source of a Pre-Programmed Device

You may receive your Breakout Board after it has been reprogrammed by someone else. To restore the board to 
the factory default, see the Download Demo Designs section for details on downloading and reprogramming the 
device.

You can also determine which demo design is currently programmed onto the Breakout Board by comparing the 
JEDEC checksums against of the programming file with what is read from the programmed device.

To compare JEDEC file checksum:

1. Connect the Breakout Board to a host PC using the USB port.

2. Start ispVM and choose ispTools > Scan.
The device appears in the Device List.

3. Double-click the device row.
The Device Information dialog appears.

4. Click the Browse button.
The Save as Data File dialog appears.

5. Specify a new JEDEC Data File name and click the Save button.

6. From the Operation list choose Read and Save JEDEC and click OK.
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7. Choose Project > Download.

ispVM reads the contents from the device and writes the results to the JEDEC file specified.

Open the JEDEC file into a text editor and page to the bottom of the file. 

Note the hexidecimal checksum at the line above the User Electronic Data note line. Compare this value 
against the checksum of the original JEDEC demo programming files.

Lattice Diamond Programmer Error

Lattice Diamond 1.1 reports “File not valid error” from the Programmer interface.

Diamond 1.1 is not Programmer compatible with the MachXO2280 Breakout Board. To program the device, use 
ispVM System 17.9 or later.

Ordering Information

Description Ordering Part Number
China RoHS Environment-Friendly 

Use Period (EFUP)

MachXO2280 Breakout Board Evaluation Kit LCMXO2280C-B-EVN

Technical Support Assistance
Hotline: 1-800-LATTICE (North America)

+1-503-268-8001 (Outside North America)
e-mail: techsupport@latticesemi.com
Internet: www.latticesemi.com

Revision History
Date Version Change Summary

March 2011 01.0 Initial release.

© 2011 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as 
listed at www.latticesemi.com/legal. All other brand or product names are trademarks or registered trademarks of 
their respective holders. The specifications and information herein are subject to change without notice.

http://www.latticesemi.com/
http://www.latticesemi.com/corporate/legal/index.cfm
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Appendix A. Schematics
Figure 9. MachXO2280 Breakout Board
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Figure 10. USB Interface to JTAG
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Figure 11. Connectors and LEDs
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Figure 12. MachXO2280
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Appendix B. Bill of Materials
Table 16. MachXO2280 Breakout Board Bill of Materials

Item Quantity Reference Part Number

1 2 C3, C12 ECJ-1VB0J475K

2 38
C4, C5, C6, C7, C8, C9, C13, C14, C15, C17, C20, C21, C23, C24, C25, 
C26, C27, C28, C29, C32, C33, C34, C35, C36, C37, C38, C39, C44, 
C45, C46, C47, C48, C49, C50, C51, C52, C53,  C56

C0402C104K4RACTU

3 2 C10, C16 ECJ-1VB0J106M

4 1 C11 LMK212BJ226MG-T

5 2 C18, C19 C0402C180K3GACTU

6 8 D1, D2, D3, D4, D5, D6, D7, D8 LTST-C190KRKT

7 1 D9 LTST-C190KGKT

8 1 J1 DNI

9 1 J2 5075BMR-05-SM-CR

10 8 J3, J4, J5, J6, J7, J8, J9, J10 DNI

11 1 J11 DNI

12 3 L1, L3, L4 BLM18AG601SN1D

13 1 R1 RC0402FR-071KL

14 18 R2, R3, R4, R7, R9, R17, R18,  R19, R47, R48, R53, R54, R55,  R56, 
R57, R58, R160, R162 RC0603JR-070RL

15 5 R11, R14, R15, R16, R20 RC0402FR-075K1L

16 1 R12 RC0402FR-0712KL

17 2 R21, R161 RC0402FR-0710KL

18 1 R22 RC0402FR-072K2L

19 8 R39, R40, R41, R42, R43, R44, R45, R46 RC0402FR-07470RL

20 4 R49, R50, R51, R52 RC0402FR-0710RL

21 101

R59, R60, R61, R62, R63, R64,  R65, R66, R67, R68, R69, R70, R71, 
R72, R73, R74, R75, R76, R77, R78, R79, R80, R81, R82, R83, R84, 
R85, R86, R87, R88, R89, R90, R91, R92, R93, R94, R95, R96, R97, 
R98, R99, R100, R101, R102, R103, R104, R105, R106, R107, R108, 
R109, R110, R111, R112, R113, R114, R115, R116, R117, R118, R119, 
R120, R121, R122, R123, R124, R125, R126, R127, R128, R129, R130, 
R131, R132, R133, R134, R135, R136, R137, R138, R139, R140, R141, 
R142, R143, R144, R145, R146, R147, R148, R149, R150, R151, R152, 
R153, R154, R155, R156, R157, R158, R159

RC0402FR-07100RL

22 10 TP1, TP2, TP3, TP4, TP5, TP6,  TP7, TP8, TP9, TP10 DNI

23 1 U1 NCP1117ST33T3G

24 1 U2 FT2232HL

25 1 U3 93LC56T-I/SN

26 1 U6 DNI

27 1 X1 7M-12.000MAAJ-T
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