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1. Introduction

Thank you for your interest in the CY3664-EXT enCoRe™ III Development Kit. 

The enCoRe III development system is based on the highly refined PSoC® Programmable System-
on-Chip™ tools. For debugging encore III, customers are requested to purchase CY3215-DK.
CY3215-DK has an in-circuit emulator (ICE) that works in conjunction with the actual silicon to
provide an accurate and efficient development system. The PSoC Designer™ software consists of a
graphical user interface, assembler, C compiler, linker, and debugger for a highly integrated code
development environment. A compliant Full-Speed USB user module, along with other peripheral
user modules, simplifies the learning curve and speeds development time.

Getting Started on page 7 of this document describes the installation and configuration of the
CY3664-EXT enCoRe III Development Kit. Kit Operation on page 13 describes the kit operation.
Hardware on page 15 describes the hardware operation. Code Examples on page 25 discusses the
code examples provided along with the kit. The Appendix on page 37 provides the schematics and
bill of materials (BOM) associated with the kit.

1.1 Kit Contents

The CY3664-EXT enCoRe III Development Kit provides only the enCoRe III specific items for
customers who already have the base in-circuit emulator in the CY3215-DK.

The CY3664-EXT enCoRe III Development Kit contains:

■ enCoRe III application board, including enCoRe III on-chip debugger (OCD) and solderless 
breadboard 

■ Jumper wire kit 

■ MiniProg Programmer

■ Standard A to Mini-B USB cable

■ 110 ~ 240-V switch mode power supply and universal power adapter 

■ CY7C64215-56LTXC samples (3) 

■ Kit CD/DVD with documents & Firmware sources

Visit http://www.cypress.com/shop for more information. Inspect the contents of the kit. If any parts
are missing, contact your nearest Cypress sales office for further assistance.

1.2 Additional Learning Resources

Visit http://www.cypress.com for additional learning resources in the form of data sheets, technical
reference manual, and application notes.

■ MiniProg –  http://www.cypress.com/?rID=37459

■ PSoC Designer Training - http://www.cypress.com/?rID=40543

■ enCoRe III Overview - http://www.cypress.com/?id=177

http://www.cypress.com/shop
http://www.cypress.com
http://www.cypress.com/?rID=37459
http://www.cypress.com/?rID=40543
http://www.cypress.com/?id=177
http://www.cypress.com/?rID=3411
http://www.cypress.com/?rID=3411
http://www.cypress.com/?rID=3411
http://www.cypress.com/?rID=3411
http://www.cypress.com/?id=177
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1.3 Document History

1.4 Documentation Conventions 

Revision
PDF Creation 

Date
Origin of 
Change

Description of Change

** 07/29/2011 CSAI Initial version of kit guide

*A 04/09/2012 CSAI

Updated Introduction chapter on page 5 (Updated 1.1 Kit 
Contents, updated 1.2 Additional Learning Resources).

Updated Getting Started chapter on page 7 (Updated 2.1 Kit 
Installation).

Updated Kit Operation chapter on page 13 (Updated 3.2 
Emulation).

Updated Hardware chapter on page 15 (Updated 4.1 System 
Block Diagram).

Updated Code Examples chapter on page 25 (Updated 5.1 
Project1- HID_Example, updated 5.2 Project2 - 
BULK_Example,  updated 5.3 Project3 - ISOC_Example).

Table 1-1.  Document Conventions for Guides

Convention Usage

Courier New
Displays file locations, user entered text, and source code:
C:\ ...cd\icc\

Italics
Displays file names and reference documentation:
Read about the sourcefile.hex file in the PSoC Designer User Guide.

[Bracketed, Bold]
Displays keyboard commands in procedures:
[Enter] or [Ctrl] [C]

File > Open Represents menu paths: File > Open > New Project

Bold
Displays commands, menu paths, and icon names in procedures:
Click the File icon and then click Open.

Times New Roman Displays an equation: 2 + 2 = 4

Text in gray boxes Describes cautions or unique functionality of the product.
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2. Getting Started

This chapter describes the installation and configuration of the CY3664-EXT enCoRe III
Development Kit.

2.1 Kit Installation

To install the kit software, follow these steps:

1. Insert the kit CD/DVD into the CD/DVD drive of your PC. The CD/DVD is designed to auto-run 
and the Kit Installer Startup screen appears. 

You can also download the latest kit installer from http://www.cypress.com/go/CY3664-EXT. 
Download the kit installer ISO file and create an installer CD/DVD or extract the ISO using 
WinRar and install the executables.

2. Click Install CY3664-EXT enCoRe III DVK to start the installation, as shown in Figure 2-1.

Figure 2-1.  Kit Installer Startup Screen

Note If auto-run does not execute, double-click the cyautorun.exe file on the root directory of the 
CD/DVD, as shown in Figure 2-2.

http://www.cypress.com/go/CY3664-EXT
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Figure 2-2.  Root Directory of the CD/DVD

3. On the startup screen, click Next to start the installer.

4. The InstallShield Wizard screen opens with the default location for setup. You can change the 
location using Change, as shown in Figure 2-3.

5. Click Next to launch the kit installer.

Figure 2-3.  InstallShield Wizard

6. On the Product Installation Overview screen, select the installation type that best suits your 
requirement. The drop-down menu has three options - Typical, Complete, and Custom, as 
shown in Figure 2-4.

7. Click Next to start the installation.
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Figure 2-4.  Installation Type Options

8. When the installation begins, a list of all packages appears on the Installation Page. A green 
check mark appears adjacent to every package that is downloaded and installed.

9. Wait until all the packages are downloaded and installed successfully.

Figure 2-5.  Installation Page

10. Click Finish to complete the installation.
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Figure 2-6.  Installation Completion Page

Note After software installation, verify your installation and setup.
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2.2 PSoC Designer

PSoC Designer is the Integrated Design Environment (IDE) that you can use to customize your
PSoC application. The latest PSoC Designer has many new features, bug fixes, and support for new
PSoC devices.

1. Click Start > All Programs > Cypress > PSoC Designer <version> > PSoC Designer <ver-
sion>.

2. Click File > New Project, to create new project; click File > Open Project/Workspace to work 
with an existing project.

Figure 2-7.  PSoC Designer Interconnect View

3. To experiment with the code examples, go to the Code Examples chapter on page 25.

For more information about the PSoC Designer, see the PSoC Designer IDE Guide located at:
<Install_Directory>:\Cypress\PSoC Designer\<version>\Documentation
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2.3 PSoC Programmer

PSoC Programmer offers a simple GUI that connects to programming hardware and enables to
program and configure PSoC devices.

1. Click Start > All Programs > Cypress > PSoC Programmer <version> > PSoC Programmer 
<version>.

2. Select the MiniProg from Port Selection, as shown in Figure 2-8.

Figure 2-8.  PSoC Programmer Window

3. Click the File Load button from the menu bar; navigate and select the hex file to load.

4. Use the Program button to load the hex file on to the chip.

5. When programming is successful, Programming Succeeded appears in the Actions pane.

6. Close PSoC Programmer.

For more details on PSoC Programmer, see the user guide located at:
<Install_Directory>:\Cypress\Programmer\<version>\Documents.
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3. Kit Operation

The CY3664-EXT enCoRe III Development Kit provides only the enCoRe III specific items for
customers who already have the base in-circuit emulator in the CY3215-DK.

3.1 Programming the Board

The application board can be programmed using either the MiniProg or the ICE-Cube. Follow these
steps to program the application with a MiniProg:

1. Launch PSoC Programmer.

2. Connect the MiniProg to the 5-pin ISSP header on the CY3664 DVK board.

3. In PSoC Programmer, click the File Load button to load the desired binary (hex) file.

4. Select the MiniProg port.

5. Select the Power Cycle programming mode.

6. Select the 64000 device family.

7. Select the CY7C64215-56LFXC device.

8. Click Program to program through programming and verification modes.

9. When Programming Succeeded appears in the Actions pane, remove the MiniProg from the 
CY3664 application board.

Figure 3-1.  Application Board with MiniProg
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3.2 Emulation

Emulation of the device can be done using the ICE-Cube. Customers are requested to purchase
CY3215-DK. Follow these steps:

1. Launch the desired *.SOC project file from the Firmware directory.

2. Connect one end of the blue CAT 5e cable to the ICE-Cube.

3. Connect the other end of the blue CAT 5e cable to the CY3664 DVK board.

4. Select Build > Build or press F7.

5. Configure debug port setting by clicking Project > Settings > Debugger; select USB as ICE 
connected to port.

6. Select Debug > Connect.

7. Select Debug > Download to Emulator.

8. Select Debug > Go or press F5.

3.3 Jumper Setting

The HID_Example, BULK_Example, and ISOC_Example sample applications are bus-powered
designs. In these designs, the chip gets its power from the USB bus. The alternative is a self-
powered design, where the chip gets its power from the 12-V power supply provided. There are two
steps to implement a bus-powered or self-powered design. The USB device descriptors must be
correctly set up in the USB Setup Wizard and the jumpers must be configured correctly on the board.

For the HID_Example, BULK_Example, and ISOC_Example sample applications, jumpers need to
be placed for VBUS on JP3 and JP5.

http://www.cypress.com/?rID=3411
http://www.cypress.com/?rID=3411
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4. Hardware

4.1 System Block Diagram

The CY3664 enCoRe III application board has the following sections:

■ enCoRe III chip

■ USB connector

■ DB9 connector

■ ISSP header

■ I2C header

■ RS232 transceiver

■ RJ45 connector

■ Breadboard area 

■ LCD module header

■ Joystick, speaker, pushbuttons, and LEDs

■ Power LED

■ Potentiometers

Figure 4-1.  System Block Diagram
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4.2 Functional Description

The CY3664-EXT enCoRe III application board includes enCoRe III chip, mini B USB connector,
ISSP header, breadboard, RS232 transceiver, I2C header, potentiometers, LCD header, joystick,
RJ45 connector, speaker, pushbuttons, and LEDs.

The following figure shows the functional blocks on the CY3664 enCoRe III application board.

Figure 4-2.  enCoRe II Functional Blocks

4.2.1 enCoRe III Chip

The enCoRe III is based on the flexible PSoC architecture and is a full-featured, full-speed
(12 Mbps) USB part. Configurable analog, digital, and interconnect circuitry enable a high level of
integration in several consumer and communication applications.

This architecture enables to create customized peripheral configurations that match the require-
ments of each individual application. Additionally, a fast CPU, flash program memory, SRAM data
memory, and configurable I/O are included in both 28-pin SSOP and 56-pin QFN packages.

Applications

■ PC human interface devices

❐ Mouse (opto-mechanical, optical, trackball)

❐ Keyboards
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❐ Joysticks

■ Gaming

❐ Game pads

❐ Console keyboards

■ General purpose

❐ Barcode scanners

❐ POS terminal

❐ Consumer electronics

❐ Toys

❐ Remote controls

❐ USB to serial

Figure 4-3.  Schematic View of Chip
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Table 4-1.  Pin Details of enCoRe III

4.2.2 USB B Connector

The USB B connector port on the application board is used to communicate with the PC. It also sup-
plies input voltage to power the board.

Figure 4-4.  Schematic View of USB Connector

Pin Name Description

1 GND Ground connection

2 P0.7 Analog column mux input

3 P0.5 Analog column mux input and column output

4 P0.3 Analog column mux input and column output

5 P0.1 Analog column mux input

6 P2.5

7 P2.3 Direct switched capacitor block input

8 P2.1 Direct switched capacitor block input

9 P1.7 I2C SCL

10 P1.5 I2C SDA

11 P1.3

12 P1.1 I2C SCL, ISSP-SCLK

13 GND Ground connection

14 D+ USB D+

15 D- USB D–

16 VDD Supply Voltage

17 P1.0 I2C SCL, ISSP-SDATA

18 P1.2

19 P1.4

20 P1.6

21 P2.0 Direct switched capacitor block input

22 P2.2 Direct switched capacitor block input

23 P2.4 External analog ground (AGND) input

24 P0.0 Analog column mux input

25 P0.2 Analog column mux input and column output

26 P0.4 Analog column mux input and column output

27 P0.6 Analog column mux input

28 VDD Supply voltage
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4.2.3 ISSP Header

In-system serial programmer (ISSP) is used to program the device. Programming can be done using
the MiniProg programmer device or ICE-Cube.

Figure 4-5.  Schematic View of ISSP Connector

4.2.4 I2C Header

The I2C header on the application board is used for I2C communication between the PC and the
board.

Figure 4-6.  Schematic View of I2C Header
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4.2.5 RS-232 Transceiver

The terminal J1 is a DB9 connector, which is connected to the RS-232 transceiver (IC U2) for serial
communication between the application board and the PC. 

Figure 4-7.  Schematic View of DB9 Connector

4.2.6 RJ45 Connector

The ICE-Cube debugger allows to debug and view the content of specific memory locations. The
ICE-Cube debugger can be connected to the RJ45 connector on the board to connect to the on-chip
debugger (OCD) device to enable debugging.

Figure 4-8.  Schematic View of RJ45 Connector
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4.2.7 Breadboard Area

This area on the board is available for customized prototyping.

Figure 4-9.  Schematic View of Prototyping Area

4.2.8 LCD Header

The LCD header is provided to connect an LCD interface for character output display. The LCD con-
trast is varied using the LCD contrast potentiometer R3. The regulated voltage Vo from R3 decides
the contrast. D0 to D7 are the data bus line for LCD, RS is the instruction/data register select pin and
R/W is Data Read/Write pin.

Figure 4-10.  Schematic View of LCD Header
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4.2.9 Joystick, Speaker, Pushbuttons, and LEDs

The application board is provided with a joystick, speaker, two pushbuttons, and four LEDs for gen-
eral use.

Figure 4-11.  Schematic View of Pushbuttons and LEDs

4.2.10 Power LED

The LED5 is used to indicate the power status of the board.

Figure 4-12.  Schematic View of Power LED
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4.2.11 Potentiometers

There are three potentiometers on the application board. Potentiometers R6 and R7 are used to vary
input voltage to the ADC connected to the pin 12 and 13 of J2. The potentiometer R3 is used to vary
LCD contrast connected to Vo pin on the LCD header.

Figure 4-13.  Schematic View of Potentiometers

4.3 Power Supply System

The power supply system on this board is versatile; it takes input supply from the following sources:

■ USB B port

■ ISSP connector

■ RS-232 port

■ RJ45 connector

■ I2C connector

■ 12 V power supply

Figure 4-14.  Power Supply System Structure

 

 

12 V DC Supply

USB

ISSP I2C

VDD VCC

VBUS

Voltage
Regulator

Vin Vreg

ICE Connector

VDD
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Figure 4-15.  Schematic View of Power Supply System Structure
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5. Code Examples

All code examples are available on the kit CD or at the following location:
<Install_Directory>\Cypress\CY3664-EXT enCoRe III DVK\<version>\Firmware\.

5.1 Project1- HID_Example

5.1.1 Project Description

The HID_Example demonstrates the basic functionality of a USB HID mouse. A complete USB HID
descriptor is provided that allows enumeration on any USB host that supports a HID device.

To run the HID_Example, follow these steps:

1. Open the HID_Example project in PSoC Designer. The project file is located at 
Firmware\HID_Example\HID_Example.SOC.

2. Build the project: select Build > Build, press F7, or select the Build icon.

3. Program the CY3664-EXT enCoRe III Development Kit board with the HID_Example.hex file, 
located at Firmware\HID_Example\HID_Example\output\.

4. On the CY3664 DVK board, attach a wire from P00 on J5 to S1 on J2.

5. On the PC, open a simple drawing application, such as Paint.

6. Connect the Mini-B side of the USB A - Mini B cable to the CY3664 DVK board.

7. Connect the A side of the USB A - Mini B cable to the PC.

Figure 5-1.  CY3664 Application Board
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5.1.2 Device Configuration

Figure 5-2.  Device Configuration for HID_Example
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5.1.3 Firmware Architecture

 

Enable Global Interrupt
Enable Sleep Interrupt

Initialize Draw USB Routine

Start

Loop
Forever

Clear Watchdog

If bTemp
?

bTemp = PRTODR
bTemp = bTemp & 0x01

Scan buttons and
switch On and Off

drawing

If bMove
?

bMove = Stop
bButton = Up

YesNo

bMove = Go
bButton = Down

If Should
Suspend ?

Yes

No

No

Clear Watchdog Timer

Yes

A

B

Does the device need
to go into suspend
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5.1.4 Verify Output

1. The HID_Example enumerates on the PC as a bus-powered USB mouse device. It will transmit  
mouse down and mouse movement commands to the PC over the USB Interrupt pipe. Within a 
simple drawing or paint application, the word “USB” is drawn as the cable is connected to the 
computer. "USB" stops drawing when S1 button is pressed. Pressing the S1 button starts or 
stops the drawing.

2. When using any of the enCoRe III examples provided, a USB analyzer can be used to inspect the 
USB transactions.

 

bUsb Active = 0
Clear USB activity flag prior

to going to suspend

Int MSK2 | = 0x80 Enable the USB wake interrupt
when the device goes to sleep,
so that USB activity will wake it

up.

If Should
Suspend &&

(!bUsb Active) ?

Clear Watchdog Timer and sleep

bUsbActive = USB bCheckActivity()

Check for USB
Activity

Yes

PRTODR & = ~0x02

No

OSC_CR0 = (OSC_CR0 & ~OSC_CR0_SLEEP) | OSC_CR0_SLEEP_512Hz
Configure Sleep Timer
to 512Hz or every 2ms

Reset Suspend Timer
Should Suspend = False

B

A
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5.2 Project2 - BULK_Example

5.2.1 Project Description

The BULK Example demonstrates the simplicity in accessing SRAM directly from the enCoRe III
USB SIE. This example uses the Bulk_Ping application to send and receive data over the Bulk IN
and OUT endpoints.

1. Open the Bulk Example project in PSoC Designer. The project file is located at 
Firmware\BULK_Example\BULK_Example\BULK_Example\BULK_Example.soc.

2. Build the project: select Build > Build, press F7, or select the Build icon.

3. Program the CY3664 DVK board with the Bulk_Example.hex file located at 
Firmware\BULK_Example\BULK_Example\output.

4. Connect the Mini-B side of the USB A to mini-B cable to the CY3664 DVK board.

5. Connect the A side of the USB A to mini-B cable to the PC.

6. After connecting USB cable to PC, Windows Hardware wizard pops up. In Win XP(32/64) OS    
Select "Yes, this time only" and click Next. In Windows Vista/7 machine choose "Browse My 
computer for driver software".

7. Choose “Install from a list or specific location” and click Next. Then choose “Dont search. I 
will choose the driver to install” and click Next.  Select “Universal Serial BUs Controllers” 
from the list of devices. In the next window select Click “Have Disk”. 

8. To select the driver matching VID/PID in the  Bulk_Example.hex select the cyusb3664extdvk.inf 
file located at <Installed_Directory>\Cypress\CY3664-EXT enCoRe III DVK\<version>\Drivers. In 
Windows Vista/7 machines browse directly after step-6 to matching Driver information file as 
mentioned below. User need to select the cyusb3664extdvk.inf and cyusb.sys file combination 
relevant to Windows OS version to which the USB cable is connected. Following are paths

a. WinXP-32-bit:wxp\x86

b. WinXP-64-bit:wxp\x64

c. WinVista-32-bit:wlh-vista\x86

d. WinVista-64-bit:wlh-vista\x64

e. Win7-32-bit:wlh-win7\x86

f. Win7-64-bit:wlh-win7\x64

9. Open Device Manager by typing “devmgmt.msc” in Windows-->Start-->Run. Expand the list   of 
USB controllers and observe Encore III DVK enumerated and listed as "Cypress encoreIII DVK 
Bulk Example (3.4.5.000)". 

10.The cyusb3664extdvk.inf, cyusb.sys and cyusb3664extdvk.cat are part of signed USB driver 
packages for all 6 Windows OS platforms - WinXP(32/64), Win Vista(32/64)and Win-7(32/64). 
Any modification to the cyusb3664extdvk.inf file would result in Invalid driver signature.The 
supplied package should be used without modification only to validate the examples provided 
with the kit.

11.The cyusb3664extdvk.inf contains Bulk example VID/PID-0x04B4/0x07B3. Customers who 
intend to utilise the existing driver package and develop their own enCore III products should 
modify the Vendor ID (VID), product ID (PID) and Product Strings contained in the 
cyusb3664extdvk.inf file. Once the cyusb3664extdvk.inf is edited the Microsoft digital signature 
for the kit driver package is no longer valid. 

12.To modify the .INF during product development press F8 during reboot select “Disable Driver 
signature enforcement”. This will enable loading of these unsigned driver package (edited 
cyusb3664extdvk.inf and cyusb.sys) in Windows PC.This modification will not propogate till next 
reboot of Windows PC. Customers can validate their modifications in the .INF temporarily using 
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this method. After completely validating the driver package customer needs digital signature(get 
catalog (.cat) files) for the driver through Microsoft WHQL program to avoid driver loading 
warnings. For more details about the Microsoft WHQL process refer to Application note titled -
"Windows Hardware Quality Labs WHQL) Signing Procedure for Customer modified Cypress 
USB Driver Files". 

Note: If the driver matching sequence (selecting cyusb3664extdvk.inf and cyusb.sys) of anyone of
examples - Bulk Example and ISOC Example is performed earlier then the remaining example’s step
6–9 can be avoided as the cyusb3664extdvk.inf file contains VID/PID entries of both these firmware
examples. 

5.2.2 Device Configuration

Figure 5-3.  Device Configuration for BULK_Example

http://www.cypress.com/?docID=35070
http://www.cypress.com/?docID=35070
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5.2.3 Firmware Architecture
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5.2.4 Verify Output

The BULK Example enumerates on the PC using the cyusb.sys driver provided with the enCoRe III
DVK. Using the Bulk_Ping_Host.exe application, data can be transferred to and from the 
CY3664-EXT enCoRe III Development Kit board. Observe Bulk packets in chunks of 64 bytes sent
continously for 30 iterations. This confirms the Bulk packets were sent in IN and OUT direction. 
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5.3 Project3 - ISOC_Example

5.3.1 Project Description

The ISOC_Example demonstrates how to create an alternative interface for isochronous
applications. This example uses the Streamer application to send data over the ISOC IN endpoint.
To run the ISOC Example, follow these steps:

1. Open the ISOC Example project in PSoC Designer. The project file is located at 
Firmware\ISOC_Example\ISOC_Example\ ISOC_Example.SOC.

2. Build the project: select Build > Build, press F7, or select the Build icon.

3. Program the CY3664 DVK board with the ISOC_Example.hex file located at 
Firmware\ISOC_Example\ISOC_Example\ISOC_Example\output\.

4. Connect the Mini-B side of the USB A to mini-B cable to the CY3664 DVK board.

5. Connect the A side of the USB A to mini-B cable to the PC.

6. After connecting USB cable to PC , Windows Hardware wizard pops up .In Win XP(32/64) OS.    
Select “Yes, this time only” and click Next. In Windows Vista/7 machine choose “Browse My 
computer for driver software”.

7. Choose "Install from a list or specific location" and click Next. Then choose “Dont search. I 
will choose the driver to install” and click Next. Select "Universal Serial BUs Controllers" 
from the list of devices. In the next window select Click “Have Disk”. 

8. To select the driver matching VID/PID in the ISOC_Example.hex select the cyusb3664extdvk.inf 
file located at <Installed_Directory>\Cypress\CY3664-EXT enCoRe III DVK\<version>\Drivers. In 
Windows Vista/7 machines browse directly after step-6 to matching Driver information file as 
mentioned below. User need to select the cyusb3664extdvk.inf and cyusb.sys file combination 
relevant to Windows OS version to which the USB cable is connected. Following are paths:

a. WinXP-32-bit:wxp\x86

b. WinXP-64-bit:wxp\x64

c. WinVista-32-bit:wlh-vista\x86

d. WinVista-64-bit:wlh-vista\x64

e. Win7-32-bit:wlh-ws\x86

f. Win7-64-bit:wlh-ws\x64

9. Open Device Manager by typing “devmgmt.msc” in Windows-->Start Button-->Run. Expand the 
list of USB controllers and observe Encore III DVK enuemrated and listed as “Cypress encoreIII 
DVK ISOC Example (3.4.5.000)”.

10. The cyusb3664extdvk.inf, cyusb.sys and cyusb3664extdvk.cat are part of signed USB driver 
packages for enCore III device for all 6 Windows OS platforms-WinXP(32/64), Win Vista(32/64) 
and Win-7(32/64). Any modification to the cyusb3664extdvk.inf file would result in Invalid driver 
signature. The supplied package should be used without modification only to validate the 
examples provided with the kit.

11.The cyusb3664extdvk.inf contains ISOC example VID/PID-0x04B4/0x07B4. Customers who 
intend to utilise the existing driver package and develop their own enCore III products should 
modify the Vendor ID(VID), product ID(PID) and Product Strings contained in the 
cyusb3664extdvk.inf file.Once the cyusb3664extdvk.inf is edited the Microsoft digital signature 
for the kit driver package is no longer valid.

12.To modify the .INF during product development press F8 during reboot select “Disable Driver 
signature enforcement”. This will enable loading of these unsigned driver package (edited 
cyusb3664extdvk.inf and cyusb.sys) in Windows PC.This modification will not propogate till next 
reboot of Windows PC. Customers can validate their modifications in the .INF temporarily using 
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this method. After completely validating the driver package customer needs digital signature (get 
catalog (.cat) files) for the driver through Microsoft WHQL program to avoid driver loading 
warnings. For more details about the Microsoft WHQL process refer to Application note titled -
”Windows Hardware Quality Labs WHQL) Signing Procedure for Customer modified Cypress 
USB Driver Files”.

Note: If the driver matching sequence (selecting cyusb3664extdvk.inf and cyusb.sys) of anyone of
examples - Bulk Example and ISOC Example is performed earlier then the remaining example’s step
6–9 can be avoided as the cyusb3664extdvk.inf file contains VID/PID entries of both these firmware
examples. 

5.3.2 Device Configuration

Figure 5-4.  Device Configuration for ISOC_Example

http://www.cypress.com/?docID=35070
http://www.cypress.com/?docID=35070
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5.3.3 Firmware Architecture
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5.3.4 Verify Output

The ISOC Example enumerates on the PC using the cyusb.sys driver provided with the enCoRe III
DVK. Launch the Streamer.exe application located at <Installed_Directory>\Cypress\
\CY3664-EXT enCoRe III DVK\<version>\software\Streamer.exe.Click on the endpoint column to
select the row. Select Alt-1 Setting listed in the drop down menu. This selects the alternative
interface containing the isochronous IN endpoint. Enter any sample value for parameter “Packets
per Xfer” = 64,128..etc. Also enter "Xfers to Queue" = 4. Click Start button on the right side of
endpoint available for streaming. There is only one endpoint available in this example for streaming.
Observe data being continously streamed and the throughput displayed. 
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A.1 Schematic
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A.2 Board Layout

A.2.1 PDC-9258 Top

 



CY3664-EXT enCoRe III Development Kit User Guide, Doc. #: 001-71694 Rev. *A 39

A.2.2 PDC-9258 Bottom
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A.3 Bill of Materials

No. Qty. Description Designator Footprint Manufacturer Mfr. Part No.

1 5 Capacitor C1, C3, C4, C5, C6 CC2012-0805 Panasonic ECJ-2VF1C105Z

2 1 Capacitor C2 CC2012-0805 Kemet
C0805C102K1RAC
TU

3 2 Capacitor C7, C8 CC2012-0805 Panasonic ECJ-2VF1H104Z

4 2 Capacitor C9, C12 EIA3216-18 Panasonic ECS-T0JY106R

5 1 Capacitor C10 EIA7343-31 EPCOS Inc B45197A2107K409

6 1 Capacitor C11 RB3.5X8 Nichicon UVZ1C471MPD

7 1 Capacitor C13 CC2012-0805 Kemet
C0805C101K5GAC
TU

8 2
1 Amp General Purpose 
Rectifier

D1, D2 SMB Diode Diodes Inc S1AB-13

9 1
3M solderless breadboard 
super strip

H1
BBoard3.25x2.12
5

na na

10 1 Female DB-9 J1 DB9F AMP/Tyco Elec 747844-2

11 1 Header, 14-Pin J2 HDR1X14 3M/ESD 929850-01-36-10

12 2 Header, 4-Pin J3, J7 HDR1X4 3M/ESD 929850-01-36-10

13 5 8-Pin Header, Female J4, J5, J6, J8, J9 HDR8X1 3M/ESD 929850-01-36-10

14 2 Header, 2-Pin, Female J10, J11 HDR2x1 3M/ESD 929850-01-36-10

15 2 Header, 10-Pin J12, J13 HDR1X10 3M/ESD 929850-01-36-10

16 1 Power connector J14 PWRCON CUI Inc PJ-102A

17 1 ICE Connection J15 RJ45 Amp/Tyco 558341-1

18 1 ISSP Conn J16 ISPCON Molex/Waldom 22-23-2051

19 8 Header, 2-Pin, Male
JP1, JP2, JP3, JP4, 
JP5, JP6, JP7, JP8

HDR2x1 Sullins PZC36SAAN

20 1 Mini Joystick JS1
CTS_MiniStick_25
2

CTS Corp 252A103B60NB

21 1
Standard 14 pin LCD inter-
face

LCD1
LCDMODULE-
T14

3M/ESD 929850-01-36-10

22 5 Red LED
LED1, LED2, LED3, 
LED4, LED5

LED0805 Lumex
SML-LXT0805IW-
TR

23 1 Silkscreen Cypress Logo LO1 CYLOGO  na

24 1 Loudspeaker LS1 CEM-1206S CUI INc CEM-1206S

25 1 USB type B connector P1
USB_MINI-
B_TMP

Moles/Waldom WM5974-ND

26 1 Header, 8-Pin, Dual row P2 HDR2X8REV Sullins PZC36DAAN

27 1 Header, 3-Pin P3 HDR1X3 Sullins PZC36SAAN

28 1 250 mA PTC PTC1 1206 Littlefuse Inc 1206L025YRT

29 1
NPN General Purpose 
Amplifier

Q1 SOT23-3 Zetex Inc FMMT491ATA

30 11 Resistor, SMT
R1, R8, R11, R12, 
R13, R15, R23, 
R24, R25, R26, R29

R2012-0805 Panasonic ERJ-6GEYJ102V

31 1 Resistor, SMT R2 R2012-0805 Panasonic ERJ-6GEYJ104V

32 3 Potentiometer R3, R6, R7 POT-3352T Bourns Inc 3352T-1-103

33 2 Resistor, SMT R4, R5 R2012-0805 Panasonic ERJ-6GEYJ220V
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34 2 Resistor, SMT R9, R10 R2012-0805 Panasonic ERJ-6GEYJ272V

35 2 Resistor, SMT R14, R21 R2012-0805 Panasonic ERJ-6GEY0R00V

36 4 Resistor, SMT R16, R17, R18, R19 R2012-0805 Panasonic ERJ-6GEYJ560V

37 1 Resistor, SMT R20 R2012-0805 Panasonic ERJ-6ENF1240V

38 1 Potentiometer R22 POT3361P Bourns Inc 3361P-1-501G

39 1 Resistor, SMT R27 R2012-0805 Panasonic ERJ-6ENF3740V

40 1 Resistor, SMT R28 R2012-0805 Panasonic ERJ-6ENF4420V

41 2 Swtich, SPST S1, S2 SW_SPST6.5/4.5 Omron B3F-1022

42 7 Simple Test point
TP1, TP2, TP3, 
TP4, TP5, TP6, TP7

TP64
Keystone, Pana-
sonic

5006

43 1 Radon OCD Part U1 100TQFP Cypress CY7C642DK-AXC

44 1
RS-232 tranceiver (1.0uF 
Caps) 3.0 - 5.0 Vcc

U2 SO-16 TI MAX3232IDR

45 1 Voltage Regulator U3 TO-220
National Semicon-
ductor

LM1117T-ADJ

No. Qty. Description Designator Footprint Manufacturer Mfr. Part No.
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